Vulnerabilidad crítica en BIND 9: CVE-2015-5477

Se ha detectado una vulnerabilidad grave con puntuación de CVSS de 7.8 en todas las versiones de 9 de Bind que provocan, debido a un fallo en la gestión de las peticiones TKEY, un ataque de denegación de servicio y por consiguiente el fallo completo de Bind. La vulnerabilidad tiene el identificador CVE-2015-5477.

El ataque DoS tampoco puede mitigarse con la funcionalidad de ACLs de Bind ya que el bug tiene lugar antes de que se consulten las tablas de acceso de control. Tanto servidores autoritativos como recursivos se ven afectado por el fallo.

No existe workaround aplicable por lo que la solución pasa únicamente por actualizar y aplicar los parches correspondientes facilitados tanto en los repositorios oficiales de cada distribución como por parte directa de Bind (sitio web de isc):

  • BIND 9 version 9.9.7-P2
  • BIND 9 version 9.10.2-P3

Para instalaciones por paquete de Debian, RHEL, CentOS, SuSe, etc podéis parchear utilizando el gestor de paquetes correspondiente (yum, apt, etc).

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *