Postfix + MailScanner: You must upgrade your perl IO module to at least…

Hoy actualizando un sistema CentOS me he encontrado con una serie de problemas de transacciones/dependencias con ciertos módulos de Perl:

conflicts between attempted installs of perl-5.8.8-10.el5_2.3 and perl…

Me he visto en la obligación de desinstalarlos, lógicamente, luego me he encontrado con algún problemilla, concretamente con MailScanner, el error era el siguiente:

# ./MailScanner start
Starting MailScanner daemons:
         incoming postfix:                                 [  OK  ]
         outgoing postfix:                                 [  OK  ]
         MailScanner:      

**** ERROR: You must upgrade your perl IO module to at least
**** ERROR: version 1.2301 or MailScanner will not work!

                                                           [  OK  ]

El error no puede ser más descriptivo, simplemente he reinstalado el módulo perl IO vía cpan y solucionado, Postfix + MailScanner funcionando perfectamente:

# cpan

cpan> install IO

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *