Verificar funcionamiento correo SMTP vía TELNET

Algo extremadamente útil y que supongo la mayoría conoceréis (esto va para los que no lo conozcan…) es poder chequear de forma rápida y sencilla si un servidor de correo SMTP está funcionando de forma correcta o no.
Normalmente un usuario corriente configuraría la cuenta de correo en su cliente, como por ejemplo Outlook o Thunderbird, una pérdida de tiempo que podemos evitar si utilizamos TELNET para hacer un test de conexión o envío de correo contra ese SMTP.
A continuación podéis ver el modo de establecer esta conexión y los pasos para enviar el correo:

En primera instancia conectamos vía TELNET al servidor SMTP por el puerto 25:

# telnet xx.xx.xx.xx 25
Trying xx.xx.xx.xx...
Connected to xxx.xxxxxxx (xx.xx.xx.xx).
Escape character is '^]'.
220 xxxxx.xxxxxxx.com ESMTP Sendmail 8.13.8/8.13.8; Thu, 1 Oct 2009 23:12:13 +0200

Como podéis apreciar, el primer paso lo hemos pasado con éxito, hemos podido acceder al servidor SMTP. Ahora vamos a decir al servidor SMTP quienes somos, hay que identificarse (normalmente nos identificamos con el nombre de nuestro PC, por ejemplo):

helo alex.portatil

Y el servidor nos responde correctamente:

250 xxxx.xxxxxxxxx.com Hello xxxx.xxxxxxx [xx.xx.xx.xx], pleased to meet you

Ya estamos en disposición de enviar el correo, primero decimos desde que cuenta vamos a enviarlo:

mail from: <micuenta@midominio.com>

Si recibimos una respuesta 250 OK todo va bien:

250 2.1.0 <micuenta@midominio.com>....Sender OK

Ahora toca poner la cuenta a la que vamos a enviar:

 rcpt to: <destino@sudominio.com>

Y si la respuesta sigue siendo 250, todo correcto:

  250 2.1.5 destino@sudominio.com

Lo siguiente será el cuerpo del mensaje (data), escribimos data y presionamos enter:

data

Escribiremos el cuerpo del correo, para acabar Enter + . + Enter (.)
Tened en cuenta que dentro del “data” podemos especificar el asunto del correo, el nombre del remitente, etc:

subject: Asunto del correo
to: destino@sudominio.com
esto es una prueba

Ya podemos salir del Telnet y el correo se enviará al destino indicado:

quit

La secuencia completa:

# telnet xx.xx.xx.xx 25
Trying xx.xx.xx.xx...
Connected to xxx.xxxxxxx (xx.xx.xx.xx).
Escape character is '^]'.
220 xxxxx.xxxxxxx.com ESMTP Sendmail 8.13.8/8.13.8; Thu, 1 Oct 2009 23:12:13 +0200
helo alex.portatil
250 xxxx.xxxxxxxxx.com Hello xxxx.xxxxxxx [xx.xx.xx.xx], pleased to meet you
mail from: <micuenta@midominio.com>
250 2.1.0 <micuenta@midominio.com>....Sender OK
rcpt to: <destino@sudominio.com>
250 2.1.5 destino@sudominio.com
data
Esto es un mail de prueba

.
quit

Nota: Si necesitáis probar una cuenta con autenticación, tendréis que usar el método SMTP AUTH, lo explicaré otro día en profundidad, aunque si buscáis en google encontraréis rápido cómo hacerlo (SMTP AUTH, SMTP Authentication Telnet).

11 comentarios en “Verificar funcionamiento correo SMTP vía TELNET

  1. hola tengo un problema al hacer me sale todo hasta el momento de poner data me sale al final

    250 2.0.0 ok queued as 28A6D5BBB

    y se me va a la cola de correos y todos los correos que envio desde los clientes a otros lientes con tuntherbind se me van a la cola no se porque ayuda porfavor¡¡¡

    • Hola,

      necesitamos más información del fichero de log, pega unas cuantas de líneas aquí o usa pastebin para que podamos echarle un vistazo. Seguramente es porque algo no está bien configurado.

      Saludos.

  2. Buenos dias gracias por este post, quisiera por favor si me puedes ayudar. tengo problemas de envio de correo, los clientes de la empresa se quejan constantemente que los correos e4nviados desde nuestro dominio les llegar repetidos hasta 25 veces y mas, ya descartamos el antivirus, el internet de la empresa, por ultimo el administrador de hosting nos dice que todo esta bien, haciendo pruebas de conectividad hacia el servidor de correo en ciertas horas de la tarde presenta caida de paquetes bastante altos, quisiera saber si hay alguna forma de comprobar de manera ditecta esta falla

  3. hola,
    tengo instalado postfix sobre ubuntu y al configurar los usuarios en evolution me sale un error:
    conexion rehusada.
    ¿Alguien sabe la solucion?
    Gracias!

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *